Приветствую Вас, уважаемые эксперты. Есть задачка по формулам ддля Excel. Сама задача описана внутри. Буду рада помощи.

1. есть цифры от 1 до 22 включительно
2. мне к цифре надо добавить +3, например, есть цифра 5, тогда 5+3=8, НО, если у нас есть цифры такие, как 20, 21, 22, то у нас появляется условие суммирования. 20+3= не 23, а итог «1» (то есть 20+1=21+1=22+1=1, так как конечное число не должно быть больше 22-х). 21+3=не 24, а итог «2» (то есть 21+1=22+1=1+1=2, так как конечное число не должно быть больше 22-х). 22+3= не 25, а итог «3» (то есть 22+1=1+1=2+1=3, так как конечное число не должно быть больше 22-х).
3. мне от цифры нужно отнять -3, например, есть цифра 5, тогда 5-3=2, НО, если у нас есть цифры такие, как 3, 2, 1, то у нас появляется условие минусования. 3-3= не 0, а итог «22» (то есть 3-1=2-1=1-1=22, так как конечное число не должно быть равно или меньше 0). 2-3=не -1, а итог «21» (то есть 2-1=1-1=22-1=21, так как конечное число не должно быть равно или меньше 0).1-3= не -2, а итог «20» (то есть 1-1=22-1=21-1=20, так как конечное число не должно быть равно или меньше 0).
==============
Получается, тут нужны две формулы. Делается только на двузначных числах. Буду рада помощи. Мой мозг что-то не фурычит :)
Можно обойтись и одной формулой, Если использовать остаток от деления. Функция ОСТАТ(число; делитель)
можете написать ОСТАТ(число+3; делитель) или ОСТАТ(число-3; делитель)
число — это у вас та цифра, которая была вначале, а делитель — 22.
Если остались вопросы или я не  совсем понял задание — обращайтесь в чат.
17.09.17
формула для сложения =ОСТАТ(число+3;22)
формула для вычитания =ЕСЛИ(число-3>0; число-3;(число-3)+22*(ЦЕЛОЕ(ABS(число-3)/22)+1))
, где число это либо исходное число или ячейка в которой это число содержится, либо формула, результат которой является требуемым числом
если число находится в ячейке A1, то
формула для сложения =ОСТАТ(A1+3;22)
формула для вычитания =ЕСЛИ(A1-3>0;A1-3;(A1-3)+22*(ЦЕЛОЕ(ABS(A1-3)/22)+1))
20.12.17
По мнению автора лучший ответ отсутствует.

Елена Васильевна

Читать ответы

Виктор Щебетун

Читать ответы

Иван Катихин

Читать ответы
Посмотреть всех экспертов из раздела Учеба и наука > Информатика
Пользуйтесь нашим приложением Доступно на Google Play Загрузите в App Store